45

Excel Funktion WENN (IF)

Meta

Erstellt: 4. April 2019
Modifiziert: 4. April 2019

Überblick

Meine kleine Rekapitulation der Excel “Wenn” Formel. In den Basic Programmiersprachen entspricht “Wenn” einer “IF Then Else” Anweisung.
Die Funktion besteht aus 3 Teilen:

  • Bedingung (Logische Operator und Wert)
  • Aktion wenn Aussage der Bedingung wahr ist
  • Aktion wenn Aussage der Bedingung falsch ist

“Aktion” ist fakultativ. Wenn man für “Aktion” keine Definition in der Funktion festlegt, wird bei “positiv” eine “0” (Null) und bei “negativ” das Wort “falsch” angezeigt. Beispiel einer solchen Minimal Funktion:
=WENN(ISTLEER(A1),)
=IF(ISEMPTY(A1),)

Wichtiger Hinweis, wenn auf dem Windows Computer auf dem Excel ausgeführt wird, dass Gebietsschema Schweiz eingestellt ist, muss anstatt des Strichpunktes (“;”) ein Komma verwendet werden. Analog dem US Gebietsschema. D.h. die Beispiele im Internet aus Deutschland funktionieren nur, wenn man dieses Detail beachtet.

Dieser Artikel berücksichtigt nicht die Apple Version von MS Excel. Die verwandte Funktion “WENNS” (“Select Case” in Basic Programmiersprache) als auch WENNFEHLER wird hier nicht thematisiert.

Was typisch für MS Office ist, die Schlüsselwörter werden in der Anzeigesprache der Applikation angezeigt. Wenn ich “Deutsch” wähle, dann kennt Excel nur die deutschen Schlüsselwörter. Vice versa wenn ich “Englisch” wähle. Wenn ich die Anzeigesprache von Excel ändere und neu starte, wird die Funktion in die neue Sprache übersetzt. Der Webservice “Excel Translator” bietet hier eine wertvolle Hilfe. Der Link ist im Abschnitt “Quellen” abgelegt. Hier ein Beispiel der Formel in “DE” und “EN”.

=WENN(ISTLEER(I5),”nachfragen”,WENN(HEUTE()-I5>4,”erneut nachfragen”,”OK”))

=IF(ISBLANK(I5),”nachfragen”,IF(TODAY()-I5>4,”erneut nachfragen”,”OK”))

Aus 1001 Grund ist für mich das programmieren, auch in so einfachen Fällen wie einer Funkton, immer englisch. Auch wenn Deutsch meine Muttersprache ist, so muss ich ein deutsches VBA Codestück 2x lesen, um es zu verstehen. Da es primär Anwender sind, welche in MS Office Funktion, Makros und VBA Module vewenden, ist Ihnen das technische Englisch nicht geläufig. Ausserdem haben sich die Anwender daran gewöhnt, dass die Applikationen oder Betriebssyteme eine deutsche Oberfläche (UI - User Interface) haben. Wenn ich Excel auf “Deutsch” einstelle und ich schreibe eine Funktion mit IF, dann versteht das Excel nicht und quittiert die Eingabe mit dem Fehler “#Name”.

In der Psychologie ein bekanntes Phänomen. Es gibt Tests, wo Schachmeister die Figuren auf dem Brett nach einem Bild das sie 10 Sekunden gezeigt erhielten aufstellen mussten. Das konnten sie ohne nennenswerte Probleme. Jedoch nur solange wie die Figuren nach einer Schachlogik aufgestellt waren. D.h. die Stellung der Figuren nach Schachlogik nachvollziehbar war.

Logische Operatoren

Operator | Umschreibung des Operators | Beispiel |
=
Gleich
A1 = B1
>
Grösser als
A1 > B1
>=
Gleich oder grösser
A1 >= B1
<
Kleiner als
A1 < B1
<=
Weniger oder gleich
A1 <= B1
<>
Weniger oder gleich
A1 <= B1

Logische Funktionen (Excel generell)

Funktionen | Umschreibung der Funktion | Beispiel |
IF
Eine Bedingung testen
IFS
Mehrere Bedingungen testen
NOT
Nicht bzw. negativ
if(NOT(A17="Blau"),"Grün","Blau")
AND
Alle Bedinungen müssen wahr sein
=IF(AND(B1>B2,A1<A2),"Test positiv")
OR
Eine Bedinung muss wahr sein
=IF(OR(A15="Kuh", A15="Schwein"),"Essen kochen", "")
XOR
Eine Bedinung nicht alle darf wahr sein
A1 <= B1
IFERROR
Findet Fehler
A1 <= B1

Mit Variabeln

Beispiel

Diese Tabelle ist die Ausgangslage. Im Feld ist das Datum der Offerte eingetragen. Wenn in der Spalte “Abgeschlossen” (Spalte “J”) kein Datum eingetragen ist, dann muss in der Spalte “Datum Bestätigung” (Spalte “I”) das Datum stehen, wenn der Empfänger die Offerte bestätigt hat.

Jeden Arbeitstag soll auf einen Blick erkannt werden, wo die Antwort auf die Offerte ausgeblieben ist. D.h. das Feld “Datum” (Spalte “H”) leer ist. In dem Fall muss im Feld “Nachfassen” (Spalte “K”) ein Vermerk stehen.

Der zweite Prüfpunkt ist, in in jeder Zeile wo eine Offerte nicht abgeschlossen ist und die Offerte bestätigt wurde, diese Bestätigung nicht älter als 4 Tage ist. Wenn sie älter als 4 Tage ist, soll ein Vermerk in der Spalte “Nachfassen” (Spalte “K”) eingetragen werden.

Excel Wenn

Leere Zelle?

Die Funktionen können mit dem Vergleich “=”” eine leere Zelle erkennen. Eleganter ist dafür die Funktion “Isblank” zu verwenden. Hier wird überprüft, ob in der Spalte “i” etwas (das Datum der Bestätigung) steht.

=IF(ISBLANK(I5),”nachfragen”,”OK”)

Verschachteltes WENN

Wenn die die Spalte “i” ein Datum hat, ist sollte überprüft werden ob das Datum 4 oder mehr Tage alt ist. Dazu verwende ich die in diesem Beispiel die Funktion “Today” (das heutige Datum) und ziehe das Datum das in der Zelle enthalten ist ab. Das Ergebnis ergibt die Anzahl Tage, was bei grösser / gleich 4 den Text “erneut nachfragen” in die Zelle schreibt.

=IF(TODAY()-I5>4,”erneut nachfragen”,”OK”)

Im nächsten Schritt kopple ich ich diese zwei “Wenn” Funktionen. D.h. ich überprüfe in einem ersten Schritt, ob das Feld “leer” ist. Wenn nein wird der Inhalt auf die Differenz zum heutigen Datum geprüft.

=IF(ISBLANK(I5),”nachfragen”,IF(TODAY()-I5>4,”erneut nachfragen”,”OK”))

Quellen

  1. MS: Dezimaltrennzeichen und Tausender sind falsch für das Gebietsschema Schweiz in Windows
  2. Excel meldet «Mit dieser Formel gibt es ein Problem»
  3. MS Excel-Hilfe und -Schulungen - Übersicht über Formeln in Excel
  4. MS Excel-Hilfe und -Schulungen - WENN-Funktion
  5. MS Excel-Hilfe und -Schulungen - Verwenden von verschachtelten Funktionen in einer Formel
  6. MS Excel-Hilfe und -Schulungen - WENNS-Funktion
  7. Funktionen Kriterien
  8. Verwenden der WENN-Funktion mit den Funktionen UND, ODER und NICHT
  9. NOT Operator
  10. Microsoft Excel
Letzte Änderung April 3, 2019